Semenalidery.com

IT Новости из мира ПК
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Округление значений в excel

Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “ Формат ячеек “;
  • В всплывающем окне “ Формат ячеек ” перейти на вкладку “ Число “;
  • В разделе “ Числовые форматы ” кликнуть по пункту “ Числовой “;
  • В меню окна найти пункт “ Число десятичных знаков ” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ ОК ” для сохранения настроек форматирования.

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядовбольше “0”, то число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядовменьше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Microsoft Excel

трюки • приёмы • решения

Как в Excel округлять значения

Округление чисел — распространенная задача, и Excel предоставляет достаточно функций, которые округляют значения разными путями (табл. 111.1). Вы должны понимать разницу между округлением и форматированием значения.

Когда вы форматируете число так, чтобы оно отображало определенное количество знаков после запятой, формулы, которые ссылаются на это число, работают с его фактическим значением, которое может отличаться от отображаемого. Когда вы округляете числа, то формулы, которые ссылаются на эти значения, используют округленные числа.

Таблица 111.1. Функции округления Excel

В следующих разделах приведены примеры формул, которые используют различные типы округления.

Округление до ближайшего кратного числа

Функция ОКРУГЛТ полезна для округления значений до ближайших кратных. Например, вы можете использовать ее, чтобы округлить число до ближайшего, кратного 5. Следующая формула возвращает 135: =ОКРУГЛТ(133;5) .

Округление денежных значений

Часто приходится округлять валютные значения. Например, рассчитанная цена может оказаться равной 45,78923 р. В таком случае вы захотите округлить ее до ближайшей копейки. Этот процесс может показаться простым, но для округления значений такого типа вам предлагается на выбор один из трех следующих способов:

  • в большую сторону до ближайшей копейки;
  • в меньшую сторону до ближайшей копейки;
  • до ближайшей копейки (округление может быть или в большую, или в меньшую сторону).

Следующая формула предполагает, что значение рублей и копеек содержится в ячейке А1. Формула округляет значение до ближайшей копейки. Например, если ячейка А1 содержит 12,421 р., формула возвращает 12,42 р.: =ОКРУГЛ(А1;2) .

Если вам необходимо округлить значение в большую сторону до ближайшей копейки, используйте функцию ОКРВВЕРХ. Следующая формула, например, округляет значение в ячейке А1 до ближайшей копейки (если ячейка А1 содержит значение 12.421 р., формула возвращает 12,43 р.): =ОКРВВЕРХ(А1;0,01) .

Чтобы округлить рублевое значение в меньшую сторону, используйте функцию ОКРВНИЗ. Следующая формула, например, округляет такое значение в ячейке А1 в меньшую сторону до ближайшей копейки (если ячейка А1 содержит 12.421 р., то формула возвращает 12.42 р.): =ОКРВНИЗ(А1;0,01) .

Чтобы округлить рублевое значение до пяти копеек, используйте эту формулу: =ОКРВВЕРХ(А1;0,05) .

Использование функций ЦЕЛОЕ и ОТБР

На первый взгляд, функции ЦЕЛОЕ и ОТБР могут показаться похожими. Они обе преобразовывают значение в целое число. Функция ОТБР просто удаляет дробную часть числа. Функция ЦЕЛОЕ округляет в меньшую сторону до ближайшего целого числа, основываясь на значении дробной части числа.

На практике ЦЕЛОЕ и ОТБР возвращают разные значения только при использовании отрицательных чисел. Например, эта формула возвращает -14.0: =ОТБР(-14,2) .

Следующая формула возвращает -15,0, поскольку число -14,2 округляется в меньшую сторону до следующего целого числа: =ЦЕЛОЕ(-14,2) .

Функция ОТБР принимает дополнительный (необязательный) аргумент, который может быть полезен для усечения десятичных значений. Например, следующая формула возвращает 54,33 (значение усекается до двух десятичных знаков): =ОТБР(54.3333333;2) .

Округление до N значащих цифр

В некоторых ситуациях может понадобиться округлить значение до определенного количества значащих цифр. Например, вы хотите выразить число 1432,187 в терминах двух значащих цифр (то есть как 1400,000). Число 84 356 выражается в трех значимых цифрах как 84 300.

Если значение является положительным числом без десятичных знаков, то вам поможет следующая формула. Она округляет число в ячейке А1 до двух значащих цифр. Для округления до различного количества значащих цифр замените 2 в этой формуле нужным вам числом: =ОКРУГЛВНИЗ(А1;2-ДЛСТР(А1)) .

Для нецелых и отрицательных чисел решение будет немного более сложным. Следующая формула предлагает более общее решение, округляющее значение в ячейке А1 до количества значащих цифр, указанного в ячейке А2. Эта формула работает для положительных и отрицательных целых и нецелых чисел: =ОКРУГЛ(Al;А2-1-ЦЕЛОЕ(LOG10(ABS(А1)))) .

Например, если ячейка А1 содержит число 1,27845, а в ячейке А2 хранится 3, то формула вернет 1,28000 (значение, округленное до трех значащих цифр).

В ремонт металлических дверей замков входит починка дверных петель, коробок и полотен, которые с течением времени и из-за неправильного использования могут расклеиваться и перекашиваться. Бывает так, что они просто перестают плотно держаться в массиве, потому что их плохо прижимают шурупы, которые, в свою очередь, могут выходить из массива вследствие плохо нарезанной резьбы или сырой древесины, куда они были вкручены. В результате после усыхания материала отверстия стали шире и шурупы вышли из них.

Читать еще:  Работа функции впр в excel примеры

Как округлять числа в Excel

В статье рассмотрено, как округлить число в Excel с помощью различных функций, таких как ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ и другие методы округления. Также приведены примеры формул, как округлить до целого числа, до десятых, до тысяч, до 5, 10 или 100, как округлить кратному числу, а также много других примеров.

Округлить число в путем изменения формата ячейки

Если вы хотите округлить числа в Excel исключительно для визуальной презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  1. Выберите ячейку с числами, которые вы хотите округлить.
  2. Откройте диалоговое окно « Формат ячеек », нажав Ctrl+1 или щелкните правой кнопкой мыши по ячейке и выберите « Формат ячеек » в контекстном меню.

Как округлить число в Excel – Формат ячеек
  1. Во вкладке « Число » выберите « Числовой » или « Денежный » формат и введите число десятичных знаков, которое вы хотите отобразить в поле « Число десятичных знаков ». Предварительный просмотр, как будет округлено число отобразится в разделе « Образец ».
  2. Нажмите кнопку « ОК », чтобы сохранить изменения и закрыть диалоговое окно.

Как округлить число в Excel – Округлить число, изменением формата ячейки

Обратите внимание! Этот метод изменяет формат отображения без изменения фактического значения, хранящегося в ячейке. Если вы ссылаетесь на эту ячейку в любых формулах, то во всех вычислениях будет использоваться исходное число без округления. Если вам необходимо фактически округлить число в ячейке, то используйте функции округления Excel.

Как округлить число функцией ОКРУГЛ

ОКРУГЛ – это основная функция округления чисел в Excel, которая округляет число до указанного количества знаков.

Синтаксис :

Число — любое действительное число, которое вы хотите округлить. Это может быть число или ссылка на ячейку.

Число_разрядов — количество знаков для округления числа. Вы можете указать положительное или отрицательное значение в этом аргументе:

  • Если число_разрядов больше 0, число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(17,25; 1) округляет число 17,25 до 17,3.

Чтобы округлить число до десятых, укажите в аргументе число_разрядов значение равное 1.

Как округлить число в Excel – Как округлить число до десятых

Если необходимо округлить число до сотых, задайте аргумент число_разрядов равным 2.

Как округлить число в Excel – Как округлить число до сотых

Для того чтобы округлить число до тысячных, введите 3 в число_разрядов.

Как округлить число в Excel – Как округлить число до тысячных
  • Если число_разрядов меньше 0, все десятичные разряды удаляются, а число округляется слева от десятичной точки (до десятых, до сотен, до тысяч и т. д.). Например, =ОКРУГЛ(17,25; -1) округляет 17,25 к ближайшему кратному 10 числу и возвращает в результате 20.
  • Если число_разрядов равно 0, число округляется до ближайшего целого числа (без десятичных знаков). Например, =ОКРУГЛ(17,25; 0) округляет 17,25 до 17.

На следующем изображении демонстрируются несколько примеров, как округлить число в Excel в формуле ОКРУГЛ:

Как округлить число в Excel – Примеры формул, как округлить число, функцией ОКРУГЛ

Как округлить число в большую сторону функцией ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число вверх (от 0) до заданного количества цифр.

Синтаксис :

Число — число для округления.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Вы можете указать как положительные, так и отрицательные числа в этом аргументе, и он работает как число_разрядов функции ОКРУГЛ, описанной выше, за исключением того, что число всегда округляется в большую сторону.

Как округлить число в Excel – Примеры формул, как округлить число в большую сторону, функцией ОКРУГЛВВЕРХ

Как округлить число в меньшую сторону функцией ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ в Excel делает противоположное тому, что делает ОКРУГЛВВЕРХ, т. е. округляет число вниз.

Синтаксис :

Число — число, подлежащее округлению.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Работает как аргумент число_разрядов функции ОКРУГЛ, за исключением того, что число всегда округлено в меньшую сторону.

Следующее изображение демонстрирует, как округлить число в Excel в меньшую сторону функцией ОКРУГЛВНИЗ в действии.

Как округлить число в Excel – Примеры формул, как округлить число в меньшую сторону, функцией ОКРУГЛВНИЗ

Так выполняется округление чисел в Excel. Надеюсь, теперь вы знаете, как среди всех этих способов, как округлить число в Excel, выбрать наиболее подходящий для ваших нужд.

Округление чисел в Microsoft Excel

При выполнении деления или работе с дробными числами, Excel производит округление. Это связано, прежде всего, с тем, что абсолютно точные дробные числа редко когда бывают нужны, но оперировать громоздким выражением с несколькими знаками после запятой не очень удобно. Кроме того, существуют числа, которые в принципе точно не округляются. В то же время, недостаточно точное округление может привести к грубым ошибкам в ситуациях, где требуется именно точность. К счастью, в программе имеется возможность пользователям самостоятельно устанавливать, как будут округляться числа.

Особенности округления чисел Excel

Все числа, с которыми работает Microsoft Excel, делятся на точные и приближенные. В памяти хранятся числа до 15 разряда, а отображаются до того разряда, который укажет сам пользователь. Все расчеты выполняются согласно хранимых в памяти, а не отображаемых на мониторе данных.

С помощью операции округления Эксель отбрасывает некоторое количество знаков после запятой. В нем применяется общепринятый способ округления, когда число меньше 5 округляется в меньшую сторону, а больше или равно 5 – в большую сторону.

Округление с помощью кнопок на ленте

Самый простой способ изменить округление — это выделить ячейку или группу ячеек и, находясь на вкладке «Главная», нажать на ленте на кнопку «Увеличить разрядность» или «Уменьшить разрядность». Обе кнопки располагаются в блоке инструментов «Число». Будет округляться только отображаемое число, но для вычислений при необходимости будут задействованы до 15 разрядов чисел.

При нажатии на кнопку «Увеличить разрядность» количество внесенных знаков после запятой увеличивается на один.

Кнопка «Уменьшить разрядность», соответственно, уменьшает на одну количество цифр после запятой.

Округление через формат ячеек

Есть возможность также выставить округление с помощью настроек формата ячеек. Для этого нужно выделить диапазон ячеек на листе, кликнуть правой кнопкой мыши и в появившемся меню выбрать пункт «Формат ячеек».

В открывшемся окне настроек формата ячеек следует перейти на вкладку «Число». Если формат данных указан не числовой, необходимо выставить именно его, иначе вы не сможете регулировать округление. В центральной части окна около надписи «Число десятичных знаков» просто укажите цифрой то количество знаков, которое желаете видеть при округлении. После этого примените изменения.

Читать еще:  Условное форматирование в excel 2020

Установка точности расчетов

Если в предыдущих случаях устанавливаемые параметры влияли только на внешнее отображения данных, а при расчетах использовались более точные показатели (до 15 знака), то сейчас мы расскажем, как изменить саму точность расчетов.

    Перейдите на вкладку «Файл», оттуда — в раздел «Параметры».

Откроется окно параметров Excel. В этом окне зайдите в подраздел «Дополнительно». Отыщите блок настроек под названием «При пересчете этой книги». Настройки в этом блоке применяются не к одному листу, а к книге в целом, то есть ко всему файлу. Поставьте галочку напротив параметра «Задать точность как на экране» и нажмите «OK».

  • Теперь при расчете данных будет учитываться отображаемая величина числа на экране, а не та, которая хранится в памяти Excel. Настройку же отображаемого числа можно провести любым из двух способов, о которых мы говорили выше.
  • Применение функций

    Если же вы хотите изменить величину округления при расчете относительно одной или нескольких ячеек, но не хотите понижать точность расчетов в целом для документа, в этом случае лучше всего воспользоваться возможностями, которые предоставляет функция «ОКРУГЛ» и различные ее вариации, а также некоторые другие функции.

    Среди основных функций, которые регулируют округление, следует выделить такие:

    • «ОКРУГЛ» – округляет до указанного числа десятичных знаков согласно общепринятым правилам округления;
    • «ОКРУГЛВВЕРХ» – округляет до ближайшего числа вверх по модулю;
    • «ОКРУГЛВНИЗ» – округляет до ближайшего числа вниз по модулю;
    • «ОКРУГЛТ» – округляет число с заданной точностью;
    • «ОКРВВЕРХ» – округляет число с заданной точностью вверх по модулю;
    • «ОКРВНИЗ» – округляет число вниз по модулю с заданной точностью;
    • «ОТБР» – округляет данные до целого числа;
    • «ЧЕТН» – округляет данные до ближайшего четного числа;
    • «НЕЧЕТН» – округляет данные до ближайшего нечетного числа.

    Для функций «ОКРУГЛ», «ОКРУГЛВВЕРХ» и «ОКРУГЛВНИЗ» используется следующий формат ввода: Наименование функции (число;число_разрядов) . То есть если вы, к примеру, хотите округлить число 2,56896 до трех разрядов, то применяете функцию «ОКРУГЛ(2,56896;3)». В итоге получается число 2,569.

    Для функций «ОКРУГЛТ», «ОКРВВЕРХ» и «ОКРВНИЗ» применяется такая формула округления: Наименование функции(число;точность) . Так, чтобы округлить цифру 11 до ближайшего числа, кратного 2, вводим функцию «ОКРУГЛТ(11;2)». На выходе получается результат 12.

    Функции «ОТБР», «ЧЕТН» и «НЕЧЕТ» используют следующий формат: Наименование функции(число) . Для того чтобы округлить цифру 17 до ближайшего четного, применяем функцию «ЧЕТН(17)». Получаем результат 18.

    Функцию можно вводить, как в ячейку, так и в строку функций, предварительно выделив ту ячейку, в которой она будет находиться. Перед каждой функцией следует ставить знак «=».

    Существует и несколько другой способ введения функций округления. Его особенно удобно использовать, когда есть таблица со значениями, которые нужно преобразовать в округленные числа в отдельном столбике.

      Переходим во вкладку «Формулы» и кликаем по кнопке «Математические». В открывшемся списке выбираем подходящую функцию, например, «ОКРУГЛ».

    После этого открывается окно аргументов функции. В поле «Число» можно ввести число вручную, но если мы хотим автоматически округлить данные всей таблицы, тогда кликаем по кнопке справа от окна введения данных.

    Окно аргументов функции сворачивается. Теперь щелкнуте по самой верхней ячейке столбца, данные которого мы собираемся округлить. После того, как значение занесено в окно, жмем по кнопке справа от этого значения.

    Опять открывается окно аргументов функции. В поле «Число разрядов» записываем разрядность, до которой нам нужно сокращать дроби и применяем изменения.

    Число округлилось. Чтобы таким же образом округлить и все другие данные нужного столбца, наводим курсор на нижний правый угол ячейки с округленным значением, жмем на левую кнопку мыши, и протягиваем ее вниз до конца таблицы.

    Теперь все значения в столбце будут округлены.

    Как видим, существуют два основных способа округлить видимое отображение числа: с помощью кнопки на ленте и путем изменения параметров формата ячеек. Кроме того, можно изменить и округление реально рассчитываемых данных. Это также можно сделать по-разному: изменением настроек книги в целом или применением специальных функций. Выбор конкретного метода зависит от того, собираетесь ли вы применять подобный вид округления для всех данных в файле или только для определенного диапазона ячеек.

    Отблагодарите автора, поделитесь статьей в социальных сетях.

    Как правильно округлить число в Excel и Google Таблицах: все способы с подробной инструкцией

    К таблицам у всех нас разное отношение, кто-то их очень любит и “рисует” по каждому поводу, кто-то терпеть не может. Но всем нам иногда приходится с ними работать, поэтому полезно знать основные возможности табличного редактора и дополнительные фишки, например, закрепление строк, использование сортировки и фильтров. Такие инструменты могут здорово облегчить жизнь.

    Сегодня же мы говорим о том, как округлить число в Excel, какие есть способы, для чего это нужно, и как правильно применять функции.

    Способы

    Под округлением каждый из нас может понимать что-то свое, поэтому давайте рассмотрим, какие варианты есть в Excel:

    1. Простое отбрасывание дробной части. Например, у нас есть число 12,3456, мы же хотим видеть только десятые и сотые доли, большая точность нас не интересует. Отбрасыванием дробной части мы получим результат 12,34. Такой способ часто используется для красоты, чтобы не перегружать таблицу и себя лишними знаками. В таком случае для решения задачи можно использовать формат ячеек.
    2. Математическое округление. В данном случае часть знаков после запятой отбрасывается, но при этом учитывается следующая цифра после значимого для нас разряда. Мы смотрим, она больше 5 или меньше. Например, у нас есть число 12,57. Мы хотим округлить его до десятых. Тогда по правилам математики мы получаем 12,6. То есть мы увеличили десятые доли на 1, потому что сотые больше 5. Если бы мы округляли 12,52, то получили бы 12,5.
    3. Округление до ближайшего большего или меньшего числа, так называемое округление “вверх” и округление “вниз” соответственно. Например, у нас есть исходные данные: 12,75, 12,31, 11,89, которые мы хотим преобразовать в целые величины. Если мы используем округление “вниз”, то получим 12, 12, 11. Если округляем в большую сторону, то получим 13, 13, 12.
    4. Округление до десятков, сотен, тысяч и так далее. Этот вариант бывает полезен, когда нам нужны приблизительные вычисления, без детализации.
    5. Округление до ближайшего четного и нечетного значения.
    6. Округление до ближайшего кратного какой-то величине числа. Например, у нас есть 124 конфеты, а в 1 коробку вмещается 13 конфет. И мы хотим понять, сколько конфет у нас разместится в коробках по 13 штук. Тогда мы будем округлять 124 до меньшего целого числа кратного 13 и получим результат 117.

    Для каждого из этих случаев в Excel есть своя функция округления. Давайте научимся ими пользоваться. Но сначала посмотрим, как можно изменить внешний вид данных в таблице.

    Формат ячеек

    Часто нам нужно не фактическое округление, а просто аккуратный единый вид всех чисел в таблице. В таком случае мы не используем формулы, а просто меняем внешний вид данных.

    Читать еще:  Как обозначить корень в excel

    Для этого выделяем ячейки в таблице и нажимаем правую кнопку мыши. В контекстном меню выбираем нужный раздел.

    Во вкладке “Число” выбираем подходящий формат.

    “Общий” используется по умолчанию и отображает данные в ячейках так, как они есть, изменить внешний вид тут не получится.

    “Числовой” позволяет отображать столько знаков после запятой, сколько нужно, или вовсе убрать дробную часть.

    “Денежный” и “Финансовый” похожи на “Числовой”, но позволяют также указывать валюту.

    В “Процентном” тоже можно регулировать количество знаков после запятой. Если мы переключаемся на этот формат, то исходные данные в ячейках умножаются на 100, и добавляется значок %.

    Я для своих вычислений чаще всего пользуюсь числовым форматом. Он универсальный и позволяет быстро привести ячейки к единому виду.

    Этот способ подходит для Excel любого года выпуска. Если у вас новая версия программы, то решить задачу можно еще быстрее. Для этого во вкладке “Главная” есть специальный блок опций. Тут можно выбрать подходящий формат из выпадающего списка, а стрелочками влево и вправо увеличить или уменьшить количество разрядов.

    Внимание: при изменении формата данных фактические значения в ячейках не меняются, они остаются прежними, просто отображаются по-другому.

    Как работать с функциями в Excel

    Мы рассмотрели самый простой способ убрать лишние знаки. Использовать его довольно удобно, если менять сами данные в таблице нам не нужно. Теперь мы переходим к использованию различных функций. Но сначала я хочу напомнить вам, что это такое, а также как с ними работать.

    Функции ускоряют и упрощают вычисления. Например, нам надо посчитать сумму в столбце, в котором 100 значений. Мы можем делать это самым прямым способом “1+20+30+43…” и так 99 раз. Или написать встроенную команду “СУММ”, указать диапазон ячеек, и программа за секунду сделает расчеты.

    Первый способ

    Чтобы вручную написать формулу в ячейке с использованием функции, обязательно нужно:

    1. Поставить знак =.
    2. Правильно указать название.
    3. Открыть круглую скобку.
    4. Указать через точку с запятой аргументы, то есть данные, которые будут использоваться.
    5. Закрыть скобку.

    Что может выступать аргументом математических формул:

    Пример: функция “=СУММ(F21:F30)” посчитает сумму чисел, написанных в столбце F с позиции F21 до F30.

    Эти правила нужно запомнить, иначе программа не сможет сделать вычисления, а будет выдавать ошибку такого вида.

    Второй способ

    Если неудобно писать команды вручную, то можно воспользоваться библиотекой, которая находится во вкладке “Формулы”.

    Нас в данный момент интересуют математические операции. Нажимаем на соответствующий раздел и выбираем нужную процедуру.

    Откроется диалоговое окно, в котором легко понять, какие аргументы нужно указать. Заполните поля и нажмите “ОК”.

    Отбрасывание дробной части

    Этот способ подойдет, если нам не важно, произойдет ли округление по математическим законам, и в какую сторону изменится значение. Когда мы просто хотим упростить вычисления, убрав лишние знаки, то можем отбросить их. Для этого есть функция “ОТБР”, которая содержит 2 параметра:

    • число, над которым нужно произвести действие;
    • количество знаков после запятой, которое следует оставить.

    Например, у нас есть цена товара 4 716 рублей 77 копеек и еще уйма знаков после запятой. Логично отбросить все лишнее и получить только рубли и копейки.

    Если же мы хотим получить только рубли без копеек, то вторым аргументом пишем не 2, а 0.

    Математическое округление

    Для привычного нам со школы математического действия есть специальная функция “ОКРУГЛ”. Она нужна для работы с дробными частями и целочисленными значениями. Аргументами выступают число и количество разрядов, которые нужно оставить после запятой.

    Например, у нас есть значение 34,83021, и мы хотим округлить его с точностью до сотых. Тогда формула будет выглядеть так: “=ОКРУГЛ(34,83021;2)”.

    Если в качестве второго аргумента указать 0, то получим целочисленное значение, то есть округлим первоначальные данные до единиц. А если количество разрядов будет отрицательным, то преобразовываться будет уже целое число.

    Например, мы хотим округлить до сотен 1245,329. Тогда делаем такую запись в ячейке нашей таблицы: “=ОКРУГЛ(1245,329;-2)” и получаем результат 1 200.

    В меньшую и большую сторону

    Бывает так, что нам не нужно точное математическое вычисление, а важно не преувеличить или, наоборот, не уменьшить значение в ячейке. Тогда мы будем округлять в меньшую или большую сторону.

    До дробных частей

    Чтобы округлить в меньшую или большую сторону, есть универсальные функции “ОКРУГЛВНИЗ” и “ОКРУГЛВВЕРХ”. Они позволяют делать преобразования с точностью до целых и дробных частей.

    Первый аргумент – это число, которое требуется округлить. Второй – количество разрядов. Если он больше 0, то показывает, сколько знаков после запятой должно остаться, если меньше 0, то происходит округление до десятков, сотен, тысяч. Если аргумент равен 0, то мы получаем точность до единиц, дробная часть отбрасывается.

    Давайте посмотрим на примере работу этих двух команд.

    До целых

    Есть еще один способ округлить в меньшую или большую сторону. Для этого нам понадобятся функции “ОКРВНИЗ” и “ОКРВВЕРХ”. Они применяются для получения целочисленного результата.

    Второй аргумент показывает, до какого разряда мы округляем:

    • 10 – до десятков;
    • 100 – до сотен;
    • 1 000 – до тысяч и т. д.

    Показываю на примере.

    Округление “вниз” до единиц можно заменить функцией “ЦЕЛОЕ”, у которой есть единственный аргумент – число. Результат будет таким же, как при использовании “ОКРВНИЗ”.

    Округлить в большую сторону до ближайшего четного или нечетного целого значения помогают действия “ЧЁТН” и “НЕЧЁТ”. Пример использования одного из них вы видите на скриншоте.

    До целых с учетом кратности

    Помните пример с конфетами, который был в начале статьи? Сейчас мы научимся округлять до ближайшего кратного какой-то величине значения. Для этого служат 2 функции: “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Первая уменьшает исходную величину, а вторая соответственно увеличивает.

    Например, у нас есть число 124, и мы хотим округлить его до ближайшего большего кратного 5 значения. Тогда пишем в ячейке: “=ОКРВВЕРХ.МАТ(124;5)” и в результате получаем 125.

    В Google Таблицах

    Если вы любите работать в режиме онлайн, то можете задать формулу для округления данных в Google Таблицах.

    Чтобы изменить формат ячеек, используйте опцию на основной панели инструментов.

    Для уменьшения или увеличения разрядности также есть соответствующий инструмент.

    Чтобы открыть перечень встроенных формул, нажмите на маленький черный треугольник рядом со значком суммы.

    Чтобы округлить данные в ячейках, наводим курсор на математические функции и выбираем один из вариантов:

    Работают они точно так же, как в Excel, но в Google Таблицах нет действий “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Вместо них можно использовать “ОКРУГЛТ”, эта функция округляет до ближайшей кратной определенному числу величины. То есть в данном случае программа сама решает, в большую или меньшую сторону изменятся исходные данные.

    Заключение

    Мы рассмотрели все основные способы округления чисел в Microsoft Excel и Google Таблицах. Конечно, есть много частных случаев, которые требуют нетривиального решения. Если вы столкнулись с ситуацией, которая не описана в этой статье, напишите комментарий, и я постараюсь помочь и подсказать, как правильно составить формулу.

    Ссылка на основную публикацию
    Adblock
    detector