Semenalidery.com

IT Новости из мира ПК
2 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

If в excel примеры

Функция if в excel примеры с несколькими условиями

Функции программы Microsoft Excel: оператор «ЕСЛИ»

​Смотрите также​ сравнить с проходным​Обычно сочетается с другими​ которыми будем работать):​ чтобы программа правильно​ в ячейке A4,​ вставить в ячейку​ настроить в соответствии​ границы можно ввести​ условий. Понятно, что​ значение. Это показано​ подписки на Office​выберите​Если A6 (25) НЕ​

​Общие сведения об использовании​ из нескольких условий.​

Общее определение и задачи

​ то выводимый результат​Среди многих функций, с​ баллом. И проверить,​ операторами.​Выделяем первую таблицу. Условное​ распознала текст.​ возвращается «ОК», в​ A1 листа.​ с конкретными требованиями.​ в соседний столбец​ 1 значение использовать​ в строках 6​ 365. Если вы​

​Условное форматирование > Создать правило​ больше 50, возвращается​ этих функций по​Итак, предположим, что премия​ зависит уже от​

Пример использования

​ которыми работает программа​ чтобы по математике​ЕСЛИ​ форматирование – создать​

​​ противном случае —​Чтобы переключиться между просмотром​1​ и организовать попарное​ бессмысленно, для этого​ и 7 примера​ являетесь подписчиком Office​. Затем выберите параметр​ значение ИСТИНА, в​ отдельности см. в​ к 8 марта​ второго оператора.​ Microsoft Excel, следует​ оценка была не​Проверяет истинность логического выражения​ правило – использовать​Часто на практике одного​ «Неверно» (ОК).​ результатов и просмотром​2​ сравнение списков с​ есть функция ЕСЛИ().​ 1 (с 58​

​ 365, Убедитесь, что​Использовать формулу для определения​ противном случае возвращается​ следующих статьях: И,​ в 100 рублей​

​Для примера возьмем все​ выделить функцию «ЕСЛИ».​ ниже «4». В​ и возвращает соответствующий​ формулу для определения​ условия для логической​=ЕСЛИ(ИЛИ(A5<>«Винты»; A6<>«Шурупы»); «ОК»; «Неверно»)​ формул, возвращающих эти​3​ помощью формулы массива:​ Чаще всего функцией​

​ баллами).​ у вас есть​ форматируемых ячеек​ значение ЛОЖЬ. В​

Пример функции с несколькими условиями

​ ИЛИ, НЕ. При​ положена только женщинам,​ ту же таблицу​ Это один из​ графе «Результат» поставить​ результат.​ форматируемых ячеек:​ функции мало. Когда​Если значение в ячейке​ результаты, нажмите клавиши​4​=И(A18:A21>B18:B21)​ И() на истинность​

​ Если условие​ последнюю версию Office.​, введите формулу и​ этом случае значение​ сочетании с оператором​ которые входят в​ с выплатами премии​ тех операторов, к​ «принят» или «нет».​#ИМЯ?​В строку формул записываем:​ нужно учесть несколько​ A5 не равно​ CTRL+` (апостроф) или​5​Вместо диапазона с границами​ проверяется 2-5 условий.​лог_выражение​

​УСЛОВИЯ([условие1; значение1;[условие2; значение2];. [условиe127; значение127])​ примените формат.​ не больше чем​ ЕСЛИ они расшифровываются​ число основного персонала.​ к 8 марту.​ которым пользователи прибегают​Введем формулу вида: =4;СУММ(B3:D3)>=$B$1);»принят»;»нет»)’​«Логическое_выражение» при вычислении должно​ =СЧЕТЕСЛИ (сравниваемый диапазон;​ вариантов принятия решений,​ строке «Винты» или​ на вкладке​6​ можно также использовать​Сама по себе функция​указывается без соответствующего​Примечания:​»Изменить правило» с​ 50, поэтому формула​ следующим образом:​

​ В этом случае,​ Но, на этот​ чаще всего, при​ class=’formula’>. Логический оператор​

​ иметь результат «ИСТИНА»​ первая ячейка первой​ выкладываем операторы ЕСЛИ​

Пример с выполнением двух условий одновременно

​ значение в ячейке​Формулы​7​ константу массива:​ И() имеет ограниченное​ аргумента​

​ ​ параметром «Формула»» />​ возвращает значение ИСТИНА.​И​ если работник мужчина,​ раз, согласно условиям,​ выполнении задач в​ «И» заставляет функцию​ или «ЛОЖЬ».​ таблицы)=0. Сравниваемый диапазон​ друг в друга.​ A6 не равно​в группе​8​=И(A18:A21><9:25:29:39>)​ использование, т.к. она​значение_если_истина​Функция ЕСЛИМН позволяет проверить​Вот как будут выглядеть​=ЕСЛИ(НЕ(A7=»красный»);ИСТИНА;ЛОЖЬ)​: =ЕСЛИ(И(условие; другое условие);​ или относится к​ размер премии зависит​ приложении. Давайте разберемся,​ проверять истинность двух​ЕСЛИОШИБКА​ – это вторая​

​ Таким образом, у​ строке «Шурупы», возвращается​Зависимости формул​9​

Пример использования оператора «ИЛИ»

​Во многих задачах требуется​ может вернуть только​, появляется сообщение «Указано​ до 127 различных условий.​ формулы для примеров​Если значение A7 («синий»)​ значение, если ИСТИНА;​

​ вспомогательному персоналу, то​ от категории работника.​ что представляет собой​ условий. Математическая функция​Если значение первого аргумента​ таблица.​ нас получиться несколько​ «ОК», в противном​нажмите кнопку​10​ проверить истинность условия​ значения ИСТИНА или​ недостаточно аргументов».​Например:​ с датами:​ НЕ равно «красный»,​ значение, если ЛОЖЬ)​ величина его премии​ Женщины, имеющие статус​ функция «ЕСЛИ», и​

​ «СУММ» используется для​

​ истинно, то возвращает​Чтобы вбить в формулу​ функций ЕСЛИ в​ случае — «Неверно»​Показать формулы​11​ или выполнить логическое​ ЛОЖЬ, чаще всего​ Если аргумент​Расшифровка:​Формула​ возвращается значение ИСТИНА,​

Использование ЕСЛИ с функциями И, ИЛИ и НЕ

​ будет равна нулю,​ основного персонала получают​ как с ней​ подсчета итогового балла.​ сам аргумент. В​ диапазон, просто выделяем​ Excel.​

​ (Неверно).​.​12​ сравнение выражений. Для​

​ ее используют вместе​лог_выражение​если(значение A1 равно 1,​Описание​ в противном случае​: =ЕСЛИ(ИЛИ(условие; другое условие);​​ а иначе –​​ по 1000 рублей​ работать.​Функция ЕСЛИ позволяет решать​​ противном случае –​​ его первую ячейку​Синтаксис будет выглядеть следующим​​=ЕСЛИ(ИЛИ(A2<>A3; A2<>A4); «ОК»; «Неверно»)​​Скопировав пример на пустой​A​ создания условных формул​ с функцией ЕСЛИ():​принимает значение, отличное​ вывести 1, если​

Технические сведения

​=A2>B2​ возвращается значение ЛОЖЬ.​ значение, если ИСТИНА;​ 1000 рублей. В​ премии, а вспомогательный​

​Скачать последнюю версию​

​ многочисленные задачи, поэтому​ значение второго аргумента.​

Функция ЕСЛИ (IF) в Excel — правила использования, примеры

Функция ЕСЛИ() применяется для выборки значения (-ий) по заданному условию (-ий). Аргументы функции:

Аргумент Лог_выражение применяется для записи непосредственно условия поиска. Возвращает логические значения «истина» или «ложь». Для формирования условия, значения можно брать как из ячеек, так и записывать непосредственно в формуле.

Два остальных аргумента — для вывода значения, если первый аргумент вывел «истину» и второй если вывел «ложь».

Например, требуется сравнить два значения и вывести в ячейке большее значение. Синтаксис формулы такой:

Читать еще:  Как поставить автонумерацию в excel

=ЕСЛИ(B2>C2;B2;C2) – читается так, если значение B2 больше C2 выводим B2, иначе C2:

Тоже самое можно сделать для разных форматов, например, для текста:

В этом примере я проверяю значение ячейки B4 и если там слово «яблоко» (написано непосредственно в строке условия, в двойных кавычках), то показать слово «фрукт». Аргументы если «истина» и, если «ложь» являются не обязательными, в случае их отсутствия, при выполнения условия будет выводиться слово «истина» или слово «ложь».

В моем примере, если написать в B4 любое другое слово программа скажет:

Примеры функции ЕСЛИ(IF) с несколькими условиями.

Часто бывает, что необходимо использовать два и более условия. Для решения этой задачи мы будем вкладывать функцию в функцию.

Возьмем предыдущий пример, и напишем дополнительное условие для слова груши:

Читается так: если B4 равно «яблоко», то выводим слово «фрукт», иначе (выполняем следующую функцию ЕСЛИ) если B4 равно «груша», то выводим слово «фрукт», иначе выводим «не фрукт».

Таких вложений может быть до 64!

Функция ЕСЛИ() выполняет условия строго по порядку и завершает свою работу, если условие было выполнено.

Это очень важное замечание в использовании формулы его необходимо учитывать. Приведу пример поломанной логики:

У нас есть таблица фруктов с количеством и себестоимостью, а нам надо определить исходя из себестоимости, нашу наценку для получения итоговой цены. Также у нас есть таблица наценок, которые зависят от себестоимости фрукта:

Применяем такую формулу:

и протягиваем ее:

Получаем 10% для всех значений. Формула начинается работу с первого аргумента – он возвращает истину, и формула завершает свою работу.

Здесь спасти положение может только добавление в функцию ЕСЛИ() функцию И(), для проверки в каком диапазоне находится себестоимость, и какую наценку надо выводить:

Примеры использования функции ЕСЛИ()

Заменим в предыдущем примере столбец наценка на столбец цена и будем выводить сразу итоговую цену. Формула примет следующий вид:

Главное не запутаться в скобках . Протягиваем формулу:

На этом все, если у вас есть вопросы оставляйте в комментариях.

Функция ЕСЛИ() в EXCEL

Функция ЕСЛИ() относится к наиболее часто используемым функциям.

Синтаксис функции

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. =ЕСЛИ(A1>=100;»Бюджет превышен»;»ОК!») Т.е. если в ячейке A1 содержится значение большее или равное 100, то формула вернет ОК!, а если нет, то Бюджет превышен .

В качестве аргументов функции, могут участвовать формулы, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше, то по столбцу С .

Вложенные ЕСЛИ

В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() . =ЕСЛИ(A1>=100;»Бюджет превышен»;ЕСЛИ(A1>=90;»Крупный проект»;ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

=ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

Опущен третий аргумент [значение_если_ложь]

Третий аргумент функции не обязателен, если его опустить, то функция вернет значение ЛОЖЬ (если условие не выполнено). =ЕСЛИ(A1>100;»Бюджет превышен») Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

Т.к. значение ЛОЖЬ эквивалентно 0, то формулы =ЕСЛИ(0;»Бюджет превышен»;»ОК!») или (если в ячейке A1 содержится значение 0) =ЕСЛИ(A1;»Бюджет превышен»;»ОК!») вернут ОК!

Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен . Такой подход удобен, когда проверяется равенство значения нулю.

Связь функции ЕСЛИ() с другими функциями использующие условия

EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;»>10″) . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

Использование оператора «ЕСЛИ» в Microsoft Excel

Среди многих функций, с которыми работает Microsoft Excel, следует выделить функцию «ЕСЛИ». Это один из тех операторов, к которым пользователи прибегают чаще всего при выполнении задач в программе. Давайте разберемся, что представляет собой эта функция и как с ней работать.

Общее определение и задачи

«ЕСЛИ» является стандартной функцией программы Microsoft Excel. В ее задачи входит проверка выполнения конкретного условия. Когда условие выполнено (истина), то в ячейку, где использована данная функция, возвращается одно значение, а если не выполнено (ложь) – другое.

Читать еще:  Функция впр в excel видео

Синтаксис этой функции выглядит следующим образом: «ЕСЛИ(логическое выражение; [функция если истина]; [функция если ложь])» .

Пример использования «ЕСЛИ»

Теперь давайте рассмотрим конкретные примеры, где используется формула с оператором «ЕСЛИ».

  1. Имеем таблицу заработной платы. Всем женщинам положена премия к 8 марту в 1000 рублей. В таблице есть колонка, где указан пол сотрудников. Таким образом, нам нужно вычислить женщин из предоставленного списка и в соответствующих строках колонки «Премия к 8 марта» вписать по «1000». В то же время, если пол не будет соответствовать женскому, значение таких строк должно соответствовать «0». Функция примет такой вид: «ЕСЛИ(B6=»жен.»; «1000»; «0»)» . То есть когда результатом проверки будет «истина» (если окажется, что строку данных занимает женщина с параметром «жен.»), то выполнится первое условие — «1000», а если «ложь» (любое другое значение, кроме «жен.»), то соответственно, последнее — «0».
  2. Вписываем это выражение в самую верхнюю ячейку, где должен выводиться результат. Перед выражением ставим знак «=».

Так мы получили таблицу со столбцом, заполненным при помощи функции «ЕСЛИ».

Пример функции с несколькими условиями

В функцию «ЕСЛИ» можно также вводить несколько условий. В этой ситуации применяется вложение одного оператора «ЕСЛИ» в другой. При выполнении условия в ячейке отображается заданный результат, если же условие не выполнено, то выводимый результат зависит уже от второго оператора.

  1. Для примера возьмем все ту же таблицу с выплатами премии к 8 марта. Но на этот раз, согласно условиям, размер премии зависит от категории работника. Женщины, имеющие статус основного персонала, получают бонус по 1000 рублей, а вспомогательный персонал получает только 500 рублей. Естественно, что мужчинам этот вид выплат вообще не положен независимо от категории.
  2. Первым условием является то, что если сотрудник — мужчина, то величина получаемой премии равна нулю. Если же данное значение ложно, и сотрудник не мужчина (т.е. женщина), то начинается проверка второго условия. Если женщина относится к основному персоналу, в ячейку будет выводиться значение «1000», а в обратном случае – «500». В виде формулы это будет выглядеть следующим образом: «=ЕСЛИ(B6=»муж.»;»0″; ЕСЛИ(C6=»Основной персонал»; «1000»;»500″))» .
  3. Вставляем это выражение в самую верхнюю ячейку столбца «Премия к 8 марта».

Как и в прошлый раз, «протягиваем» формулу вниз.

Пример с выполнением двух условий одновременно

В функции «ЕСЛИ» можно также использовать оператор «И», который позволяет считать истинной только выполнение двух или нескольких условий одновременно.

  1. Например, в нашей ситуации премия к 8 марта в размере 1000 рублей выдается только женщинам, которые являются основным персоналом, а мужчины и представительницы женского пола, числящиеся вспомогательным персоналом, не получают ничего. Таким образом, чтобы значение в ячейках колонки «Премия к 8 марта» было 1000, нужно соблюдение двух условий: пол – женский, категория персонала – основной персонал. Во всех остальных случаях значение в этих ячейках будет рано нулю. Это записывается следующей формулой: «=ЕСЛИ(И(B6=»жен.»; C6=»Основной персонал»); «1000»; «0»)» . Вставляем ее в ячейку.

Копируем значение формулы на ячейки, расположенные ниже, аналогично продемонстрированным выше способам.

Пример использования оператора «ИЛИ»

В функции «ЕСЛИ» также может использоваться оператор «ИЛИ». Он подразумевает, что значение является истинным, если выполнено хотя бы одно из нескольких условий.

    Итак, предположим, что премия к 8 марта в 1000 рублей положена только женщинам, которые входят в число основного персонала. В этом случае, если работник — мужчина или относится к вспомогательному персоналу, то величина его премии будет равна нулю, а иначе – 1000 рублей. В виде формулы это выглядит так: «=ЕСЛИ(ИЛИ(B6=»муж.»; C6=»Вспомогательный персонал»); «0»; «1000»)» . Записываем ее в соответствующую ячейку таблицы.

«Протягиваем» результаты вниз.

Как видим, функция «ЕСЛИ» может оказаться для пользователя хорошим помощником при работе с данными в Microsoft Excel. Она позволяет отобразить результаты, соответствующие определенным условиям.

Отблагодарите автора, поделитесь статьей в социальных сетях.

Примеры использования условий в формулах Excel

Здравствуйте, друзья! Часто ли вам приходится делать выбор? Например, захотели купить новый телефон, а полной суммы денег у вас нет. Взять кредит или копить? Так сегодня разберем как делать выбор в электронных таблицах Excel. Это позволяет сделать условная функция ЕСЛИ().

Условная функция ЕСЛИ()

В этой функции проверяется истинность одного или нескольких логических выражений и выбирается дальнейшее действие. В логических выражениях используют знаки операций отношения между сравниваемыми величинами.

Простое условие

Что же делает функция ЕСЛИ()? Посмотрите на схему. Здесь приведен простой пример работы функции при определении знака числа а.

Блок-схема «Простое условие». Определение отрицательных и неотрицательных чисел

Условие а>=0 определяет два возможных варианта: неотрицательное число (ноль или положительное) и отрицательное. Ниже схемы приведена запись формулы в Excel. После условия через точку с запятой перечисляются варианты действий. В случае истинности условия, в ячейке отобразится текст «неотрицательное», иначе — «отрицательное». То есть запись, соответствующая ветви схемы «Да», а следом – «Нет».

Текстовые данные в формуле заключаются в кавычки, а формулы и числа записывают без них.

Если результатом должны быть данные, полученные в результате вычислений, то смотрим следующий пример. Выполним увеличение неотрицательного числа на 10, а отрицательное оставим без изменений.

Блок-схема «Простое условие». Расчет данных

На схеме видно, что при выполнении условия число увеличивается на десять, и в формуле Excel записывается расчетное выражение А1+10 (выделено зеленым цветом). В противном случае число не меняется, и здесь расчетное выражение состоит только из обозначения самого числа А1 (выделено красным цветом).

Это была краткая вводная часть для начинающих, которые только начали постигать азы Excel. А теперь давайте рассмотрим более серьезный пример с использованием условной функции.

Задание:
Процентная ставка прогрессивного налога зависит от дохода. Если доход предприятия больше определенной суммы, то ставка налога выше. Используя функцию ЕСЛИ, рассчитайте сумму налога.

Решение:

Решение данной задачи видно на рисунке ниже. Но внесем все-таки ясность в эту иллюстрацию. Основные исходные данные для решения этой задачи находятся в столбцах А и В. В ячейке А5 указано пограничное значение дохода при котором изменяется ставка налогообложения. Соответствующие ставки указаны в ячейках В5 и В6. Доход фирм указан в диапазоне ячеек В9:В14. Формула расчета налога записывается в ячейку С9: =ЕСЛИ(B9>A$5;B9*B$6;B9*B$5). Эту формулу нужно скопировать в нижние ячейки (выделено желтым цветом).

В расчетной формуле адреса ячеек записаны в виде A$5, B$6, B$5. Знак доллара делает фиксированной часть адреса, перед которой он установлен, при копировании формулы. Здесь установлен запрет на изменение номера строки в адресе ячейки.

Составное условие

Составное условие состоит из простых, связанных логическими операциями И() и ИЛИ().

И() — логическая операция, требующая одновременного выполнения всех условий, связанных ею.
ИЛИ() — логическая операция, требующая выполнения любого из перечисленных условий, связанных ею.

Логическая операция И()

Например: Рассмотрим электронную таблицу «Ведомость сдачи вступительных экзаменов». Для зачисления абитуриента в ВУЗ, ему необходимо преодолеть проходной балл, и по математике отметка должна быть выше 70 баллов.
Посмотрите внимательно на рисунок ниже.

В этом примере функция ЕСЛИ() использует составное условие, связанное логической операцией И(). Обратите внимание: абитуриент Петров не зачислен, хотя сумма его баллов равна проходному.

Почему так произошло? Посмотрим внимательно на условие в нашей формуле =ЕСЛИ(И(E6>=D2;B6>70);»зачислен»;»не зачислен»). Логическая операция И() требует выполнения всех условий, но у нас выполняется только одно. Второе условие B6>70 не выполнено, поэтому составное условие принимает значение «ложь». И на экран выводится сообщение «не зачислен» (вспоминаем схему – ветвь «нет»).

Задание:
В торговой фирме перед Новым Годом устроена праздничная распродажа. Рассчитать сумму продаж с учетом скидки, назначаемой в период распродажи.

1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи попадает в период праздничной распродажи, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию И().

3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%).

Решение:

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке Е7: =B7*C7
  • В ячейке F7: =ЕСЛИ(И(D7>=D$4;D7

Абитуриент Сидоров зачислен, хотя не набрал проходной балл. Вот формула =ЕСЛИ(ИЛИ(B7>60;E7>D2;);»зачислен»;»не зачислен»). Здесь использована операция ИЛИ(), поэтому достаточно выполнение хотя бы одного условия. Что и произошло, первое условие B7>60 истинно. Оно привело к выводу сообщения о зачислении абитуриента.

Задание:
В торговой фирме установлены дни распродаж — последние числа месяца. Рассчитать сумму продаж с учетом скидки, назначаемой в дни распродажи.

1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи совпадает с датами распродаж, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию ИЛИ().

3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%)

Решение:

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке Е7: =B7*C7
  • В ячейке F7: =ЕСЛИ(ИЛИ(D7=D$4;D7=E$4;D7=F$4);B$4;0)
  • В ячейке G7: =E7*(1-F7)

и скопировать по соответствующим столбцам до 15 строки включительно.

Вложенные условия

Если для решения задачи недостаточно использования составных условий, то тогда применяют более сложную конструкцию вложенных условий. Смотрите схему.

В данном примере вторая функция ЕСЛИ() является вложенной и записывается на месте действия, которое вызывается при не выполнении условия первой функции. В Excel последних версий допускается делать до 64 вложений.

Задание:
С целью уменьшения текучести кадров администрация решила выплачивать надбавку за непрерывный стаж работы на своем предприятии. Рассчитайте надбавку за непрерывный стаж работы в соответствии с таблицей Надбавка.

1. Определите стаж работы сотрудников. Стаж = 2018- Год приема на работу.

2. Используя вложенные функции Если, рассчитайте надбавку для сотрудников. Надбавка (руб.) = Надбавка(%)* Оклад

Решение:

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке D9: =2018-B9
  • В ячейке E9: =ЕСЛИ(D9>=B$6;C9*C$6;ЕСЛИ(D9>=B$5;C9*C$5;0))

и скопировать по соответствующим столбцам до 19 строки включительно.

В этой статье я постарался максимально подробно и доходчиво объяснить применение условной функции в Excel. Конечно же, в Excel есть и другие функции с условием, но о них поговорим в следующей статье. Друзья, если вам была интересна и полезна данная информация, не забывайте делиться ею в социальных сетях. А также буду рад прочитать ваши комментарии.

Дополнительная информация:

PS: Удивительные факты

Ссылка на основную публикацию
ВсеИнструменты
Adblock
detector